yu

EIGRP Questions


Here you will find answers to EIGRP Questions
Question 1
Refer to the exhibit. In this network, R1 is configured not to perform autosummarization within EIGRP. What routes will R3 learn from R2 through EIGRP?
EIGRP_summary.jpg
A.    172.30.1.0/24 and 10.1.2.0/24; EIGRP only performs autosummarization at the edge between two major networks.
B.    172.30.0.0/16 and 10.1.2.0/24; R2 will perform autosummarization, although R1 will not.
C.    Since R2 is configured without autosummarization, it will not propagate the 172.30.1.0/24 route.
D.    172.30.0.0/8 and 10.0.0.0/8.

Answer: A
Explanation
EIGRP performs an auto-summarization each time it crosses a border between two different major networks. For example, in the topology below R3 will auto-summary and advertise only 10.0.0.0/8 network to R4 router.
EIGRP_summary_example.jpg
In the above question, if R1 is configured with “auto-summary”, it will advertise the summarized 172.30.0.0/16 network to R2.
Question 2
Though many options are supported in EIGRPv6, select two options from the below list that are supported. (Choose two)
A. VRF
B. auto-summary
C. per-interface configuration
D. prefix-list support via route-map
E. prefix-list support via distribute-list

Answer: C E
Explanation
Below is some information EIGRPv6:
IPv6 EIGRP and IPV4 EIGRP are very similar in concept except for the following differences:
* IPv6 is configured on interface basis (like OSPFv3 and RIPng) and networks are advertised based on interface command -> C is correct.
* When configured on interface, IPv6 EIGRP is initially placed in “shutdown” state
* As with OSPFv3, IPv6 EIGRP require a router-id in IPv4 format
* Passive interfaces can only be configured in the routing process mode
* Need for extra memory resources and supported in IOS 12.4(6)T and later
* No split horizon in IPv6 because it is possible to get multiple prefixes per interface
* No concept of classful routing in IPv6 EIGRP consequently no automatic summary -> B is not correct
EIGRPv6 uses the router configuration command “distribute-list prefix-list” to perform route filtering, and when configuring route filtering the “route-map” command is not supported -> E is correct but D is not.
Virtual Routing and Forwarding (VRF) is also supported in EIGRPv6.
    Question 3
    Refer to the exhibit. Routers A and B are directly connected. Given the configuration, how many EIGRP routes will router B see in its routing table?
    Router A relevant configuration
    interface fa0/0
    ip address 10.10.1.1 255.255.255.0
    router eigrp 100
    network 10.1.1.0 0.0.0.255
    network 10.2.1.0 0.0.0.255
    network 172.16.10.0 0.0.0.255
    network 172.16.2.0 0.0.0.255
    Router B relevant configuration
    interface fa0/0
    ip address 10.10.1.2 255.255.255.0
    router eigrp 100
    network 10.10.1.0 0.0.0.255
    eigrp stub
    A.0
    B. 1
    C.2
    D. 3
    E. 4

    Answer: A
    Explanation
    In this question, router A does not advertise its “network 10.10.1.0 0.0.0.255″ in the EIGRP process (the network connected with router B) so no EIGRP neighbor relationship is established between two routers. If we use the “show ip route” command on both routers, we just see a directly connected network 10.10.1.0/24 like this:
    Gateway of last resort is not set                                                                                                                                                                                                      
    10.0.0.0/24 is subnetted, 1 subnets                                              
    C       10.10.1.0 is directly connected, FastEthernet0/0
    For your information,  even if we use the “network 10.10.1.0 0.0.0.255″ in the EIGRP process of router A we still don’t see any EIGRP route because router A does not have any interfaces belonging to networks 10.1.1.0/24, 10.2.1.0/24, 172.16.2.0/24 -> it will not advertise these networks to router B.
    Question 4
    Refer to the exhibit. Routers A and B are directly connected and running EIGRP, but they are unable to form a neighbor relationship. What is the most likely cause?
    Router A relevant configuration:
    interface fa0/0
    ip address 10.10.10.1 255.255.255.252
    ip address 10.10.10.9 255.255.255.252 secondary
    ip address 10.10.10.5 255.255.255.252 secondary
    router eigrp 100
    network 10.10.10.0 0.0.0.255
    Router B relevant configuration:
    interface fa0/0
    ip address 10.10.10.6 255.255.255.252
    ip address 10.10.10.2 255.255.255.252 secondary
    ip address 10.10.10.10 255.255.255.252 secondary
    router eigrp 100
    network 10.10.10.0 0.0.0.3
    network 10.10.10.4 0.0.0.3
    network 10.10.10.8 0.0.0.3
    A. The network statements are misconfigured.
    B. The IP address statements are misconfigured.
    C. The autonomous system is missconfigured.
    D. There is a physical issue with the cable.

    Answer: B
    Explanation
    To form neighbor relationship in EIGRP, these conditions must be met:
    * Pass the authentication process
    * Have the same conīŦgured AS number
    Must believe that the source IP address of a received Hello is in that router’s primary connected subnet on that interface
    * Match K values
    The third item means that the primary ip address of the neighbor must be in the same subnet with the primary ip address of the received interface. But in this case the primary ip address of router A is 10.10.10.1/30 and it is not in the same subnet with the primary ip address of router B 10.10.10.6/30 -> no EIGRP neighbor relationship is formed.
    Question 5
    You add the following commands into a routed topology:
    router eigrp 1
    variance 3
    traffic-share min across-interfaces
    Users now complain about voice quality in your VoIP system. What should be done?
    A. Add the command: router eigrp 1 traffic-share voice interface fast 0/0. 
    B. Reconfigure EIGRP to recognize voice packets.
    C. Remove the variance from the configuration.
    D. Reconfigure the VoIP system to use RTP sequence number headers.
    E. Use an H.323 gatekeeper for your VoIP system to negotiate an H.245 uneven packet buffer.
    F. Reconfigure EIGRP to version 2.

    Answer: D or E
    Explanation
    This is a tough question to answer. I have no idea about the command “traffic-share min across-interfaces” and do a search and the best explanation I found is: traffic-share min command causes EIGRP to divide traffic only among the routes with the best metric. When the traffic-share min command is used with the across-interfaces keyword, an attempt is made to use as many different interfaces as possible to forward traffic to the same destination.
    Therefore with the configuration above, EIGRP will only use equal-cost load-balancing feature even when the variance command is used. However, if you use both the traffic-share min command and variance command, even though traffic is sent over the minimum-cost path only, all feasible routes get installed into the routing table, which decreases the convergence times. But the voice quality is still the same so C is not a correct answer.
    A is not correct as there is no “traffic-share voice ….” command.
    B is not correct as EIGRP can not recognize voice packets.
    F is not correct because EIGRP does not have version 2.
    Note: EIGRP routing process will install all paths with metric < best_metric * variance into the local routing table. Here metric is the full metric of the alternate path (FD) and best_metric is the metric of the primary path
    Question 6
    Based on the network displayed in the exhibit, both R1 and R2 are configured as EIGRP stub routers. If the link between R1 and R3 is down, will R3 still be able to reach 192.168.1.0/24, and why or why not?
    EIGRP_stub.jpg
    A. No. R3 would remove its route to 192.168.1.0/24 through R1, but would not query R2 for an alternate route, since R2 is a stub.
    B. No. The path through R2 would always be considered a loop at R3.
    C. Yes. When a directly connected link fails, a router is allowed to query all neighbors, including stub neighbors, for an alternate route.
    D. Yes, because R3 would know about both routes, through R1 and R2, before the link between R1 and R3 failed.

    Answer: A
    Question 7
    Study the following network topology carefully. The routers R1, R2 and R3 are connected to each other. EIGRP is running in this network. When the link between R1 and R3 is down, what will R4 receive from R3?
    EIGRP_link_down.jpg
    A. R4 will not receive any updates or queries, because R3 will simply move to the path through R2
    B. R4 will receive an update noting R3’s higher cost to reach 172.30.1.0/24
    C. R4 will receive a query, because R3 will mark 172.30.1.0/24 as active when the link between R1 and R4 failed
    D. R4 will not receive any packets, since R3 is not using the link to R1 to reach 172.30.1.0/24

    Answer: B
    Previous
    Next Post »